EWITool for Mac OS X

If you use an EWI 4000S and HATE the seemly abandoned Vyzex editor for it? Fear NOT fellow EWI players, Joseph Sheedy has come to the rescue. He has successfully compiled and released a build of the EWITool for OS X. And it works….though it is a little wonky. The interface is a little weird, and the Set Library doesn’t seem to work. The EWI Patch Set does work, which is cool. It is a community group where you can share patches you make. There are actually some nice ones there.

So, go check out EWITool. And grab the Mac version.

4 thoughts on “EWITool for Mac OS X”

  1. Just realized I messed up my Vyzex editor version 1.00 by updating my EWI4000s firmware to version 2.4. Akai doesn’t support it and Psicraft closed its download site. So I was thrilled to find this, and now I’ve tried it a bit. I was considering getting a PC just for this, but perhaps I’ll get into programming my Mac instead.
    I’m the first Commenter here, so if anyone knows how to set up the Preferences with a Library Directory path name, please chip in!
    There’s some challenges, for sure: after getting patches from EWI, window does not display bottom row containing patches numbered 20, 40, 60, 80 or 00
    Testing – I see that if I hold down Control and click one of these patches, I can load it into the Editor screen.
    Tried importing an SQS file and got the error: “! Cannot write file /Users/Username/Music/AkaiPro EWI4000s/Factory Set.SQS: unknown error” which is ironic because I wasn’t trying to write it, I was trying to import it. Tried importing a .BNK file and got the result “! Cannot write file /Applications/EWI/EWI 4000Factory Bank.BNK: Unknown error”. I wonder if this is due to path naming on the Mac (which uses the colon rather than the backslash of PC or forward slash of the Web).

    1. A year later, I must withdraw my remarks about Vyzex not working with the EWI firmware 2.4 – I finally acquired an old Mac Mini that runs on OS X 10.6, and it works as it should. So now I have Vyzex on the Mini and Ewitool on the MacBook Pro (OS X 10.9).
      Vyzex was, it turns out, incompatible with newer MAC OS X versions (10.8 and 10.9).

      1. And that is a problem. Going forward, you are going to have more and more Macs running 10.8 or higher than running 10.7 or older. It really isn’t a good solution to have someone have to have an antique mac to run their software on. Plus, is the EWI5000 going to ship like that? With the old Vyzex software?

  2. @Paul – I have the Vyzex editor working fine with the EWI at v2.4. I’m having no issues getting the editor to read/write to/from the EWI.

    If you need a copy of the Vyzex editor, it is still available from the Akai site or I can send you a copy. I know the version from Akai is good because I just recently redownloaded and reinstalled it.

    You can contact me here or through my website(s) ewilogic.com or johnisley.com

Leave a Reply